summaryrefslogtreecommitdiff
path: root/Data/BuiltIn/Libraries/luafun/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'Data/BuiltIn/Libraries/luafun/debian/rules')
-rw-r--r--Data/BuiltIn/Libraries/luafun/debian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/Data/BuiltIn/Libraries/luafun/debian/rules b/Data/BuiltIn/Libraries/luafun/debian/rules
new file mode 100644
index 0000000..9e473ed
--- /dev/null
+++ b/Data/BuiltIn/Libraries/luafun/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+VERSION := $(shell dpkg-parsechangelog|grep ^Version|awk '{print $$2}')
+UVERSION := $(shell echo $(VERSION)|sed 's/-[[:digit:]]\+$$//')
+
+%:
+ dh $@ --buildsystem=lua --with lua
+
+tarball: clean
+ tar --exclude=.git --exclude=debian --exclude rpm \
+ --transform='s,^\.,luafun-$(UVERSION),S' \
+ -czf ../luafun-$(UVERSION).orig.tar.gz .