summaryrefslogtreecommitdiff
path: root/Data/DefaultContent/Libraries/luafun/debian/rules
diff options
context:
space:
mode:
authorchai <chaifix@163.com>2021-10-26 11:32:46 +0800
committerchai <chaifix@163.com>2021-10-26 11:32:46 +0800
commit0549b1e5a8a3132005e275d6026db8003cb067d2 (patch)
treef0d7751ec32ecf5c4d23997fa0ffd3450a5a755a /Data/DefaultContent/Libraries/luafun/debian/rules
parent32345800737b668011a87328cd3dcce59ec2934c (diff)
*rename folder
Diffstat (limited to 'Data/DefaultContent/Libraries/luafun/debian/rules')
-rw-r--r--Data/DefaultContent/Libraries/luafun/debian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/Data/DefaultContent/Libraries/luafun/debian/rules b/Data/DefaultContent/Libraries/luafun/debian/rules
new file mode 100644
index 0000000..9e473ed
--- /dev/null
+++ b/Data/DefaultContent/Libraries/luafun/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+VERSION := $(shell dpkg-parsechangelog|grep ^Version|awk '{print $$2}')
+UVERSION := $(shell echo $(VERSION)|sed 's/-[[:digit:]]\+$$//')
+
+%:
+ dh $@ --buildsystem=lua --with lua
+
+tarball: clean
+ tar --exclude=.git --exclude=debian --exclude rpm \
+ --transform='s,^\.,luafun-$(UVERSION),S' \
+ -czf ../luafun-$(UVERSION).orig.tar.gz .