summaryrefslogtreecommitdiff
path: root/Resources/DefaultContent/Libraries/luafun/debian/rules
diff options
context:
space:
mode:
authorchai <chaifix@163.com>2021-10-20 12:31:42 +0800
committerchai <chaifix@163.com>2021-10-20 12:31:42 +0800
commit943411c9006345b07557e76ff360c388ee8366c1 (patch)
treef9d3e8525acd02412d1d556b6778fb373a806f33 /Resources/DefaultContent/Libraries/luafun/debian/rules
parentdcf8210b43077ed6a12d73e0d7d3d7edcbbe3e55 (diff)
+some lua libs
Diffstat (limited to 'Resources/DefaultContent/Libraries/luafun/debian/rules')
-rw-r--r--Resources/DefaultContent/Libraries/luafun/debian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/Resources/DefaultContent/Libraries/luafun/debian/rules b/Resources/DefaultContent/Libraries/luafun/debian/rules
new file mode 100644
index 0000000..9e473ed
--- /dev/null
+++ b/Resources/DefaultContent/Libraries/luafun/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+VERSION := $(shell dpkg-parsechangelog|grep ^Version|awk '{print $$2}')
+UVERSION := $(shell echo $(VERSION)|sed 's/-[[:digit:]]\+$$//')
+
+%:
+ dh $@ --buildsystem=lua --with lua
+
+tarball: clean
+ tar --exclude=.git --exclude=debian --exclude rpm \
+ --transform='s,^\.,luafun-$(UVERSION),S' \
+ -czf ../luafun-$(UVERSION).orig.tar.gz .