summaryrefslogtreecommitdiff
path: root/source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am
diff options
context:
space:
mode:
authorchai <chaifix@163.com>2019-05-11 22:54:56 +0800
committerchai <chaifix@163.com>2019-05-11 22:54:56 +0800
commit9645be0af1b1d5cb0ad5892d5464e1b23c51b550 (patch)
tree129c716bed8e93312421c3adb2f8e7c4f811602d /source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am
Diffstat (limited to 'source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am')
-rw-r--r--source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am b/source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am
new file mode 100644
index 0000000..d278644
--- /dev/null
+++ b/source/3rd-party/SDL2/src/hidapi/hidtest/Makefile.am
@@ -0,0 +1,20 @@
+AM_CPPFLAGS = -I$(top_srcdir)/hidapi/
+
+## Linux
+if OS_LINUX
+noinst_PROGRAMS = hidtest-libusb hidtest-hidraw
+
+hidtest_hidraw_SOURCES = hidtest.cpp
+hidtest_hidraw_LDADD = $(top_builddir)/linux/libhidapi-hidraw.la
+
+hidtest_libusb_SOURCES = hidtest.cpp
+hidtest_libusb_LDADD = $(top_builddir)/libusb/libhidapi-libusb.la
+else
+
+# Other OS's
+noinst_PROGRAMS = hidtest
+
+hidtest_SOURCES = hidtest.cpp
+hidtest_LDADD = $(top_builddir)/$(backend)/libhidapi.la
+
+endif