summaryrefslogtreecommitdiff
path: root/Client/ThirdParty/Box2D/docs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Client/ThirdParty/Box2D/docs/CMakeLists.txt')
-rw-r--r--Client/ThirdParty/Box2D/docs/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/Client/ThirdParty/Box2D/docs/CMakeLists.txt b/Client/ThirdParty/Box2D/docs/CMakeLists.txt
new file mode 100644
index 0000000..edffb4e
--- /dev/null
+++ b/Client/ThirdParty/Box2D/docs/CMakeLists.txt
@@ -0,0 +1,32 @@
+
+# NOTE: The order of this list determines the order of items in the Guides
+# (i.e. Pages) list in the generated documentation
+
+set(BOX2D_DOXYGEN_SOURCES
+ "include/box2d"
+ "docs/overview.md"
+ "docs/hello.md"
+ "docs/testbed.md"
+ "docs/common.md"
+ "docs/collision.md"
+ "docs/dynamics.md"
+ "docs/loose_ends.md"
+ "docs/references.md"
+ "docs/FAQ.md")
+
+# Format the source list into a Doxyfile INPUT value that Doxygen can parse
+foreach(path IN LISTS BOX2D_DOXYGEN_SOURCES)
+ set(BOX2D_DOXYGEN_INPUT "${BOX2D_DOXYGEN_INPUT} \\\n\"${CMAKE_SOURCE_DIR}/${path}\"")
+endforeach()
+
+# https://cmake.org/cmake/help/latest/command/configure_file.html
+configure_file(Doxyfile.in Doxyfile @ONLY)
+
+add_custom_target(docs ALL "${DOXYGEN_EXECUTABLE}"
+ WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/docs"
+ COMMENT "Generating HTML documentation" VERBATIM)
+
+install(
+ DIRECTORY "${CMAKE_BINARY_DIR}/docs/html"
+ DESTINATION "${CMAKE_INSTALL_DOCDIR}"
+)