summaryrefslogtreecommitdiff
path: root/Client/ThirdParty/Box2D/extern/sajson/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Client/ThirdParty/Box2D/extern/sajson/CMakeLists.txt')
-rw-r--r--Client/ThirdParty/Box2D/extern/sajson/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Client/ThirdParty/Box2D/extern/sajson/CMakeLists.txt b/Client/ThirdParty/Box2D/extern/sajson/CMakeLists.txt
new file mode 100644
index 0000000..cc23e58
--- /dev/null
+++ b/Client/ThirdParty/Box2D/extern/sajson/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_library(sajson STATIC sajson.cpp sajson.h)
+target_include_directories(sajson PUBLIC ..)
+
+set_target_properties(sajson PROPERTIES
+ CXX_STANDARD 11
+ CXX_STANDARD_REQUIRED YES
+ CXX_EXTENSIONS NO
+)
+
+source_group(TREE ${CMAKE_CURRENT_SOURCE_DIR} FILES sajson.cpp sajson.h)