summaryrefslogtreecommitdiff
path: root/Client/ThirdParty/Box2D/unit-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Client/ThirdParty/Box2D/unit-test/CMakeLists.txt')
-rw-r--r--Client/ThirdParty/Box2D/unit-test/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Client/ThirdParty/Box2D/unit-test/CMakeLists.txt b/Client/ThirdParty/Box2D/unit-test/CMakeLists.txt
new file mode 100644
index 0000000..d941579
--- /dev/null
+++ b/Client/ThirdParty/Box2D/unit-test/CMakeLists.txt
@@ -0,0 +1,18 @@
+add_executable(unit_test
+ doctest.h
+ hello_world.cpp
+ collision_test.cpp
+ joint_test.cpp
+ math_test.cpp
+ world_test.cpp
+)
+
+set_target_properties(unit_test PROPERTIES
+ CXX_STANDARD 11
+ CXX_STANDARD_REQUIRED YES
+ CXX_EXTENSIONS NO
+)
+target_link_libraries(unit_test PUBLIC box2d)
+
+source_group(TREE ${CMAKE_CURRENT_SOURCE_DIR} FILES doctest.h
+ hello_world.cpp collision_test.cpp joint_test.cpp math_test.cpp world_test.cpp )