summaryrefslogtreecommitdiff
path: root/Client/ThirdParty/imgui/examples/example_android_opengl3/android/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'Client/ThirdParty/imgui/examples/example_android_opengl3/android/app/build.gradle')
-rw-r--r--Client/ThirdParty/imgui/examples/example_android_opengl3/android/app/build.gradle34
1 files changed, 34 insertions, 0 deletions
diff --git a/Client/ThirdParty/imgui/examples/example_android_opengl3/android/app/build.gradle b/Client/ThirdParty/imgui/examples/example_android_opengl3/android/app/build.gradle
new file mode 100644
index 0000000..aa7f0ea
--- /dev/null
+++ b/Client/ThirdParty/imgui/examples/example_android_opengl3/android/app/build.gradle
@@ -0,0 +1,34 @@
+apply plugin: 'com.android.application'
+apply plugin: 'kotlin-android'
+
+android {
+ compileSdkVersion 29
+ buildToolsVersion "30.0.3"
+ ndkVersion "21.4.7075529"
+ defaultConfig {
+ applicationId "imgui.example.android"
+ minSdkVersion 23
+ targetSdkVersion 29
+ versionCode 1
+ versionName "1.0"
+ }
+
+ buildTypes {
+ release {
+ minifyEnabled false
+ proguardFiles getDefaultProguardFile('proguard-android-optimize.txt')
+ }
+ }
+
+ externalNativeBuild {
+ cmake {
+ path "../../CMakeLists.txt"
+ }
+ }
+}
+repositories {
+ mavenCentral()
+}
+dependencies {
+ implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
+}